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1. Uvod
 
Osnovna namjena programa za rad sa tabelama je da omoguće obradu numeričkih podataka ljudima koji se ne bave programiranjem. Naziv su dobili po tome što se podaci unose i prikazuju u vidu tabela, različite veličine i kompleksnosti. Za praktičan rad izabran je Microsoft Excel kao trenutno najbolji i najpopularniji program te vrste. Microsoft Excel je dio Microsoft Office paketa. U današnje vrijeme najveći konkurent Microsoft Office-u je OpenOffice.
 
Mogućnosti programa za rad sa tabelama
Moderni programi za rad sa tabelama nam osim računanja omogućavaju da unjete podatke formatiramo, izdvojimo dio podataka koji nam je bitan i prikažemo ih upotrebom različitih vrsta grafikona. Sa druge strane, od nas kao korisnika se zahtijeva da pri unosu podataka budemo sistematični i dosljedni.
 
Osnovni pojmovi:
Više podataka koji se nalaze jedan do drugog čini red. Kada se ti podaci napišu jedan ispod drugog, oni čine kolonu. Podatke raspoređene tako da se u presjeku bilo kog reda sa bilo kojoj kolonom nalazi tačno jedan podatak nazivamo tabelarno uređenim podacima. Presjek reda i kolone nazivamo ćelija. Uobičajeno je da prvi red sadrži objašnjenje šta predstavljaju podaci koje tabela sadrži i nazivamo ga zaglavlje ili zaglavlje tabele.
 
Podatke koji se mogu izračunati ne unosimo ručno, već umesto njih u tabelu upisujemo pravilo za njihovo izračunavanje. Pri radu sa Excel-om (i drugim programima za rad sa tabelama) uobičajeno je da takvo pravilo zovemo formula.
 

Odabirom najprikladnijeg grafikona Vaši će podatci biti jasnije prikazani. Microsoft Excel podržava velik broj grafikona koji Vam mogu pomoći da prikažete podatke. Ovaj će Vam maturski rad pokazati kako Vam čarobnjak za grafikone može pomoći da podatke pretvorite u prikladan grafički prikaz grafikonom.
2. Izgled radnog prostora 
Excel je program za rad sa tabelama koji možete da koristite da organizujete, analizujete i atraktivno prezentujete podatke kao što su izvještaji o budžetu ili prodaji. Svaka Excelova datoteka je radna sveska (workbook)  koja može da sadrži više radnih listova (worksheets). Radni list je rešetka – mreža kolona (columns), označenih slovima, i redova (rows), označenih brojevima. Slova i brojevi kolona i redova (nazvani oznake reda/kolone - labele – labels) prikazani su sivim dugmadima uzduž pri vrhu i na lijevoj strani radnog lista. Presjek kolone i reda, naziva se ćelija (cell). Svaka ćelija tabele ima adresu ćelije (cell address) koja je slovo kolone i broj reda. Ćelije mogu da sadrže tekst, brojeve ili matematićke formule.
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Slika 1. Radni prostor Excel-a
1 - Naslovna linija (Title bar): sadrži ime programa (Microsoft Excel), i podrazumjevano ime (default name) datoteke (Book 1) koje treba izmjeniti kada budete snimali svoj rad.
2 – Razlićite palete alatki:

a. Linija menija (Menu bar): sadrži menije koji uključuju sve komande koje su vam potrebne za rad na vaš način kroz Excel kao što su File, Edit, View, Insert, Format, Tools, Window i Help.

b. Standardna linija – paleta alatki: sadrži uglavnom prečice (shortcuts) za komande koje mogu da se nađu u menijima koji su prethodno navedeni. Oni imaju isti oblik ikone. (New, Open, Save, Print,...itd.)

c. Linija alata za formatiranje (Formatting toolbar): uglavnom se koristi ta formatiranje teksta ( vrsta – tip/ veličina/ podvlačenje/ boja vrste slova – fonta, uvlačenje teksta  (text indentation), liste sa grafičkim oznakama nabrajanja (bulleted lists) ili numerisane liste  (numbered lists), ivičnih linija (borders) ... itd).
d. Linija alata za crtanje (Drawing toolbar) (ako se nalazi na ekranu): sadrži izvjesne komande za crtanje oblika, popunjavanje bojama ... itd).
Da bi dodali ili uklonili palete – linije alata: pritisnite desni taster miša (right click) u oblast te palete alatki, i izaberite/poništite izbor (select/deselect) liniju – paletu alatki koju želite.
3 - Trake za pomeranje sadržaja ekrana (Scroll bars): omogućavaju vam da se krećete kroz  radnu svesku.

4 – Pano (okno) zadataka (Task Pane):ovo je najnovije i visoko napredno svojstvo u Microsoft Office XP paketu. Pojavljuje se kada god startujete Excel.
Da bi prikazali ili sakrili Task Pane:

Pritisnite tasterom miša na View  Task Pane
Da bi ga zatvorili (close), pritisnite na malo 'x' ([image: image2.bmp])dugme u desnom gornjem uglu.

Koji panoi zadataka su na raspolaganju u Excelu?

a. New Workbook: za otvaranje ili kreiranje novih radnih svezaka.

b. Clipboard: Prikazuje svaku stavku koju ste birali da uklonite ili kopirate

c. Search: omogućava vam da tragate za vašim radnim sveskama na vašem računaru.
d. Insert ClipArt: omogućava vam da dodate klipart likove u vaše radne listove.

1. Standardna linija – paleta alata (Standard toolbar)
Ova paleta alata smještena je odmah ispod linije menija pri vrhu ekrana i omogućava vam da brzo pristupite komandama Excela. 
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Sika 2. Standardna linija
Primjedba: Ako se ne pojavljuje cijela lista, pritisnite na dugme opcija palete [image: image4.bmp] koje je smješteno na kraju svake palete alata, i pritisnite na padajuću listu - 'privjezak' (tag) - 'Add or Remove Buttons'.
New –  Da bi kreirali novu radnu svesku, birajte File [image: image5.bmp]New  iz linije menija, ili pritisnite dugme New.

Open –  Da bi otvorili neku postojeću datoteku, pritisnite (click) File[image: image6.bmp]Open iz linije menija, ili pritisnite dugme Open.
Save – [image: image7.bmp] Da bi snimili – sačuvali (save) datoteku, pritisnite na dugme save na standardnoj paleti alata.

Odaberite direktorijum (folder) u kome ćete je čuvati, i ime datoteke, a onda pritisnite  save. Ovo se radi jedino kada prvi put pokušate da snimite – sačuvate radnu svesku/datoteku. Preporučuje se da snimate svoj rad svakih dva ili tri minuta. Sve što treba da uradite je da pritisnete na dugme save [image: image8.bmp], ili jednostavno idite na File [image: image9.bmp] Save. Ovo će ažurirati vašu početnu datoteku.
Save as: Da bi snimili različitu kopiju ili verziju:

Pritisnite na opciju 'save as' u meniju file, i sačuvajte – snimite vaš dokument pod različitim imenom.
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Slika 3. Primjena naredbe Save As.., iz File menija
Print – [image: image11.bmp] Da bi štampali radni list, odaberite File [image: image12.bmp]Print iz linije menija, ili  pritisnite na dugme Print.
Print preview [image: image13.bmp] Da bi pregledali radni list pre nego što ga štampate, odaberite File [image: image14.bmp]Print preview iz linije menija, ili pritisnite na dugme Print preview.
Spell check - [image: image15.bmp] Da bi ispravili greške u pisanju na vašem radnom listu, koristite spell checker.

Cut, Copy, Paste, [image: image16.png]SN - 4



 i Format Painter – Ove akcije, opisane su u sekciji – odeljku ‘Modifikovanje radnih listova'.
Undo i Redo - [image: image17.png]


 Da bi poništili poslednju akciju koju ste obavili,
pritisnite 'obrnutu strelicu ' - Undo, bilo da je to unošenje podataka u ćeliju, formatiranje ćelije, unošenje funkcije, itd. Da bi poništili undo akciju, pritisnite 'strelicu unapred' - Redo. 
Insert Hyperlink - [image: image18.png]2



 Da bi unjeli hipervezu (hyperlink) za Web stranu na Internetu, upišite tekst u ćeliju za koju želite da bude veza - link koja može da se ‘klikne’ mišem. Onda pritisnite dugme Insert Hyperlink i unesite Web adresu za koju želite da vežete tekst, i pritisnite OK.
Autosum, Function Wizard, i Sorting Ova svojstva se detaljno diskutuju u priručniku Functions.
Zoom – 100% Da bi promjenili veličinu u kojoj se radni list pojavljuje na ekranu, odaberite različite procente u meniju Zoom.
3. Grafikoni
Neki grafikon vam omogućava da slikovito prikažete podatke svog radnog lista, i može da vam pomogne da poredite podatke i uočite tendencije – trendove. Excel nudi više različitih vrsta – tipova grafikona. Ova stranica objašnjava kako možete da iz podataka kreirate jednostavne grafikone. Grafikone možete da kreirate na tri načina: 
Prvo odaberite podatke u vašem radnom listu koje želite da koristite u vašem grafikonu.

1. Insert > Chart , pojaviće se čarobnjak za grafikone (Chart Wizard) 

ILI 
2. Pritisnite mišem na dugme čarobnjaka za grafikone (Chart button Wizard) 

[image: image19.jpg]


 na paleti alatki Standard (Standard toolbar). 

ILI 
3. Pritisnite F11 na svojoj tastaturi. Pre nego što budete mogli da napravite grafikon, prvo morate da unesete podatke u vaš radni list. Ova stranica objašnjava kako možete da iz podataka kreirate jednostavne grafikone. 

3.1. Čarobnjak za izradu grafikona (Chart Wizard)
Čarobnjak za izradu grafikona (Chart Wizard) vodi vas kroz proces kreiranja grafikona, prikazujući seriju – niz okvira za dijalog. 

1. Unesite podatke u radni list i istaknite sve ćelije koje će da budu uključene u grafikon, uključujući i zaglavlja.
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Slika 4. Podaci unešeni u radni list
2. Pritisnite mišem dugme za čarobnjaka za izradu grafikona (Chart Wizard button) na paleti alatki Standard, da bi videli okvir za dijalog za čarobnjaka za izradu grafikona (Chart Wizard dialog box).

3. Chart Type – Odaberite Chart Type (vrsta grafikona), i ako je potrebno, Chart subtype (podvrsta grafikona). Pritisnite mišem Next.
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Slika 5. Prikaz prozora za umetanje grafikona – korak broj 1
2. Chart Suource Data (izvorni podaci za grafikon) – Odaberite opseg podataka (data range) (ako je različit od područja koje je istaknuto u koraku 1) i pritisnite mišem Next.
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Slika 6. . Prikaz prozora za umetanje grafikona – korak broj 2
5. Chart Options (opcije – mogući izbori grafikona) – Unesite ime grafikona i imena – naslove za X- i Y-ose. Druge opcije za ose (axes), linije mreže (grid lines), legendu, znake – labele podataka (data labels), i tabela podataka (data table) mogu da se menjaju pritiskanjem miša na jezičke – tabove. Pritisnite Next da bi se premestili na sledeći skup opcija.
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Slika 7. Prikaz prozora za umetanje grafikona – korak broj 3

Naslov – ime grafikona (Chart title): je naslov – ime koje vezujemo za grafikon. 

Kategorija (x) ose (Category (x) axis) : (obično vertikalna) osa koja prikazuje skalu vrednosti kojom je serija podataka merena. 
Kategorija (y) ose (Category (y) axis) : (obično horizontalna) osa koja prikazuje kategoriju oznaka – labela za sve serije podataka. 

Linije mreže (Gridlines): Možete da dodate linije mreže (gridlines) (i vertikalno i horizontalno) u vaš grafikon. Važno je da dodate linije mreže kada imate grafikon sa vrednostima koje su medjusobno bliske.

Legenda (Legend): Je obojeni (colour), tekstualni (text) ili grafički (graphic)“ključ”, koji identifikuje svaku seriju podataka u grafikonu 

Oznake – labele podataka (Data Labels): Tekst ili vrednosti prikazane u Data Points (tačke podataka)(pojedinačno nacrtane vrednosti koje su u vezi sa nekom specifičnom – posebnom kategorijom). 

Tabela podataka (Data Table): Omogućava vam da postavite tabelu ispod x-ose. Ova mogućnost poravnava brojčane podatke pod odgovarajuću kategoriju. 

6. Mesto grafikona (Chart Location)- Pritisnite mišem As new sheet (kao novi list), ako grafikon treba da bude postavljen na novi – blanko radni list, ili odaberite As object in (kao objekat u) ako grafikon treba da bude ugradjen u neki postojeći list, i odaberite radni list iz padajućeg menija. 
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Slika 8. Prikaz prozora za umetanje grafikona – korak broj 4
7. Pritisnite mišem na Finish, da biste kreirali grafikon
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Slika 9. Prikaz umetnutog grafikona u radni list
Da biste dobili paletu alatki Chart (Chart toolbar), pritisnite desnim tasterom miša uz područje palete alatki, i pritisnite mišem na chart Resizing the Chart 

Da biste izmenili veličinu grafikona, pritisnite mišem na njegovu ivicu – okvir (border), i povlačite bilo koji od devet crnih markera (black handles) za izmenu veličine. Markeri u uglovima će da izmene grafikon proporcionalno, dok će markeri duž linija da rastegnu grafikon.
3.2. Marker za izmjenu veličinu grafikona
1. Dva vertikalna srednja markera mogu da se koriste za izmenu visine grafikona

2. Dva horizontalna srednja markera mogu da se koriste za izmenu širine grafikona

3. Četiri markera u uglovima mogu da se koriste za izmenu (visine i širine) grafikona

3.3. Premještanje grafikona (Moving the Chart )

Odaberite ivicu – okvir (border) grafikona, zadržite pritisnutim levi taster miša, i odvucite grafikon na drugo mesto – lokaciju.Select the border of the chart, hold down the left mouse button, and drag the chart to a new location. 

Elementi unutar grafikona, kao što su naslov – naziv (title) i oznake – labele (labels), takodje mogu da se premeštaju unutar grafikona. Pritisnite mišem na element da biste ga aktivirali, i koristite miš da ga odvučete. 

3.4. Brisanje grafikona (Deleting the Chart)

1.
Pritisnite mišem na prazno područje u grafikonu koji želite da brišete. 
Oko grafikona će da se pojave markeri (handles).


2.
Da biste izbrisali grafikon, pritisnite taster Delete na tastaturi 
3.5. Paleta alatki za izradu garfikonima (Chart Toolbar)
Da biste pribavili paletu alatki za izradu grafikona, pritisnite desni taster miša uz područje palete alatki, i pritisnite na chart (grafikon)
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Slika 10. Prikaz tulbar-a za rad sa grafikonima
3.6. Dugmad Chart Objects List (lista objekata grafikona) i Format (formatiranje)

Da biste odabrali neki objekat za formatiranje na grafikonu, pritisnite mišem na taj objekat na grafikonu, ili odaberite objekat iz liste objekata za grafikon (Chart Objects List) i pritisnite mišem na dugme Format (Format button). Pojaviće se prozor koji sadrži svojstva tog objekta za izmenu formatiranja. 
Vrsta grafikona (Chart Type) – Da biste odabrali različite vrste grafikona, pritisnite  vrh strelice na dugmetu za vrstu grafikona (chart type button). 

Prekidač - sklopka za legendu (Legend Toggle) – Pritiskom miša na ovo dugme-sklopku (prekidač), prikazaćete ili sakriti legendu grafikona (chart legend). 

Pregled tabele podataka (Data Table view ) – Pritiskom na dugme-prekidač za tabelu podataka (Data Table toggle button), umesto grafikona, prikazaćete tabelu podataka. 

Prikazivanje podataka po kolonama ili redovima (Display Data by Column or Row) – U skladu sa listom podataka (data sheet), crta grafikon podataka po kolonama ili redovima. 

Postavljanje teksta pod uglom (Angle Text) – Odaberite osu kategorija ili vrednosti, i pritisnite mišem na dugme Angle Downward (manji ugao) ili Angle Upward (veći ugao), da biste “nagnuli” istaknuti tekst za +/- 45 stepeni. 
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Slika 11.  Prikaz umetnutog grafikona u radni list pomoću ikone sa Toolbar-a
3.7. Kopiranje grafikona u datoteku za Microsoft Office

Završeni grafikon može da bude kopiran u dokument Microsoft Office-a, kao što je na primer, Microsoft Word. Odaberite grafikon, i odaberite Edit > Copy. Otvorite odredišni dokument (destination document) u Word-u, i odaberite Edit > Paste. 

Vrste grafikona (Chart Types) 
Excel nudi različite vrste  grafikona. U ovom vežbanju, posmatraćemo dve vrste. 

1.
Stubičasti grafikoni (Column Charts) : Stubičasti grafikon ima vertikalne stupce i nacrtan je kao odvojene tačke tokom vrijemena. Stubičasti grafikoni su dobri za prikazivanje iznosa vrednosti (value amounts) i količina (quantities) tokom vrijemena 

2.
Pitoliki grafikoni (Pie Charts): Grafikoni, čiji je oblik sličan obliku pite - kružni grafikoni (Pie charts), koriste se za pokazivanje procentualnog udela u odredjenoj celini.Jedna od velikih mogućnosti koje nudi Excel sa pitolikim grafikonima, je da možete da izdvojite odredjeni – konkretan podatak (data point), i da ga odvučete iz cele “pite”, i time odvojite “krišku” (slice), takodje nazvanu “komad” (piece) ,čime ističete izvestan – konkretan podatak (data point.) 

Pregledno o formatiranju grafikona i ćelija (Charts and Cells) 

1.
Formatiranje naziva grafikona (Chart Titles): 
Pritisnite desnim tasterom miša na naziv grafikona (chart title), i odaberite “Format Chart Title” (“formatiraj naziv grafikona”) iz okvira za dijalog  Format Chart Title (Format Chart Title dialog box). Odaberite postavke za font (font settings), efekte (effects), i poravnavanje (alignment) koja želite. Pritisnite mišem na OK. 
2.
Formatiranje legendi (Legends): 
Pritisnite desnim tasterom miša na Legend, i odaberite “Format Legend” (“formatiraj legendu”) u okviru za dijalog Format legend (Format Legend dialog box.) Odaberite postavke za fontove (font settings), efekte (effects), i poravnavanje (alignment) koje želite. Pritisnite mišem na OK. 

3. 
Izmena boje pozadine (Background Color): 
Pritisnite desnim tasterom miša na područje grafikona (chart area) (belo područje), i odaberite “Format Chart Area”(“formatiraj područje grafikona”) padajućeg menija (pop up menu). Odaberite jezičak – karticu za uzorke (pattern tab), i odaberite boju koju želite. Takodje možete da odaberete područje grafikona “chart area”, ako odabetete opciju chart area iz palete alatki za grafikone (chart toolbar). 
4. 
Formatiranje naziva osa (Axis Title):      Pritisnite desnim tasterom miša na naziv ose (axis title) i iz padajućeg menija odaberite “Format Axis Title” (“formatiraj naziv ose”). Iz okvira za dijalog za formatiranje naziva osa (Format Axis Title dialog box.), odaberite postavke za fontove (font settings), efekte (effects), i poravnavanje (alignment) koje želite 

5.
 Dodavanje slika/isečenih likova (Picture/ ClipArt Image):      U vaš grafikon ili radni list, možete da dodate sliku ili već pripremljen lik pomoću:

1. Insert > Picture > ClipArt (Da ubacite neki lik iz Galerije gotovih likova -ClipArt gallery).
 
ILI

2. Insert > Picture > From File, (Da ubacite neki lik koji je memorisan na vašem lokalnom disku). 

6.
Rotiranje taksta na grafikonu:

1. Pritisnite mišem na tekst koji želite da rotirate. 


2. Pritisnite mišem na sledeću dugmad na paleti alatki za izradu grafikona (chart toolbar): 
Rotira tekst unazad (Rotate Text downward) 
Rotira tekst unapred (Rotate Text upward)
7.
Omotavanje teksta (wrapping text) u ćelijama:            Omotavanjem teksta, možete da prikažete neki dugačak red teksta unutar ćelije. 


1. Pritisnite mišem na ćeliju koja sadrži tekst koji želite da omotate 


2. Pritisnite mišem na Insert > Format Cells > Alignment tab (jezičak-karticu), a pod odeljkom Text control označite (check) the opciju “Wrap text”(“omotaj tekst”), i potvrdite pritiskom miša na OK.

3.8. Štampanje grafikona

Možete da štampate grafikon sa ili bez podataka iz radnog lista:

1. Ako istaknete grafikon koji ima podatke iz radnog lista (worksheet data), i pritisnete mišem na File > Page setup (postavka stranice), pribavićete okvir za dijalog sa jezičcima – karticama (Page - stranica, Margins - margine, Header/Footer – Zaglavlje/podnožje, Sheet - list).

2. Ako istaknete grafikon bez podataka iz radnog lista, i pritisnete mišem na File > Page setup, pribavićete okvir za dijalog takodje sa četiri jezička – kartice, ali sa Chart (grafikon), umesto sheet (list): (Page, Margins, Header/Footer, Chart – grafikon).
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Slika 12. Prikaz prozora za štampanje grafikona

Ovde imate opciju za skaliranje do ispunjenja cele stranice, ili podešavanje po svom izboru. Takodje, možete da odredite kvalitet štampanja. Sada pritisnite mišem Print Preview (prikaz – pregled pre štampanja), da biste pregledali vaš radni list (a onda, close – zatvori).
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